FreeBSD man pages : mount (8)
MOUNT(8) FreeBSD System Manager's Manual MOUNT(8)
mount - mount file systems
mount [-adfpruvw] [-t ufs | external_type]
mount [-dfpruvw] special | node
mount [-dfpruvw] [-o options] [-t ufs | external_type] special node
The mount utility calls the mount(2) system call to prepare and graft a
special device or the remote node (rhost:path) on to the file system tree
at the point node. If either special or node are not provided, the
appropriate information is taken from the fstab(5) file.
The system maintains a list of currently mounted file systems. If no
arguments are given to mount, this list is printed.
The options are as follows:
-a All the filesystems described in fstab(5) are mounted. Excep-
tions are those marked as ``noauto'', excluded by the -t flag
(see below), or if they are already mounted (except the root
filesystem which is always remounted to preserve traditional sin-
gle user mode behavior).
-d Causes everything to be done except for the actual system call.
This option is useful in conjunction with the -v flag to deter-
mine what the mount command is trying to do.
-f Forces the revocation of write access when trying to downgrade a
filesystem mount status from read-write to read-only. Also
forces the R/W mount of an unclean filesystem (dangerous; use
-o Options are specified with a -o flag followed by a comma sepa-
rated string of options. In case of conflicting options being
specified, the rightmost option takes effect. The following
options are available:
async All I/O to the file system should be done asynchronously.
This is a dangerous flag to set, and should not be used
unless you are prepared to recreate the file system
should your system crash.
When used with the -u flag, this is the same as specify-
ing the options currently in effect for the mounted
force The same as -f; forces the revocation of write access
when trying to downgrade a filesystem mount status from
read-write to read-only. Also forces the R/W mount of an
unclean filesystem (dangerous; use with caution).
fstab When used with the -u flag, this is the same as specify-
ing all the options listed in the fstab(5) file for the
Metadata I/O should be done synchronously, while data I/O
should be done asynchronously. This is the default.
Do not update the file access time when reading from a
file. This option is useful on filesystems where there
are large numbers of files and performance is more criti-
cal than updating the file access time (which is rarely
ever important). This option is currently only supported
on local filesystems.
noauto This filesystem should be skipped when mount is run with
the -a flag.
Disable read clustering.
Disable write clustering.
nodev Do not interpret character or block special devices on
the file system. This option is useful for a server that
has file systems containing special devices for architec-
tures other than its own. This option is set automati-
cally when the user does not have super-user privileges.
noexec Do not allow execution of any binaries on the mounted
file system. This option is useful for a server that has
file systems containing binaries for architectures other
than its own.
nosuid Do not allow set-user-identifier or set-group-identifier
bits to take effect. Note: this option is worthless if a
public available suid or sgid wrapper like suidperl(1) is
installed on your system. It is set automatically when
the user does not have super-user privileges.
Do not follow symlinks on the mounted file system.
rdonly The same as -r; mount the file system read-only (even the
super-user may not write it).
sync All I/O to the file system should be done synchronously.
A directory on the mounted filesystem will respond to the
SUID bit being set, by setting the owner of any new files
to be the same as the owner of the directory. New direc-
tories will inherit the bit from their parents. Execute
bits are removed from the file, and it will not be given
This feature is designed for use on fileservers serving
PC users via ftp, SAMBA, or netatalk. It provides secu-
rity holes for shell users and as such should not be used
on shell machines, especially on home directories. This
option requires the SUIDDIR option in the kernel to work.
Only UFS filesystems support this option. See chmod(2)
for more information.
update The same as -u; indicate that the status of an already
mounted file system should be changed.
union Causes the namespace at the mount point to appear as the
union of the mounted filesystem root and the existing
directory. Lookups will be done in the mounted filesys-
tem first. If those operations fail due to a non-exis-
tent file the underlying directory is then accessed. All
creates are done in the mounted filesystem.
Any additional options specific to a filesystem type that is not
one of the internally known types (see the -t option) may be
passed as a comma separated list; these options are distinguished
by a leading ``-'' (dash). Options that take a value are speci-
fied using the syntax -option=value. For example, the mount com-
mount -t mfs -o nosuid,-N,-s=4000 /dev/dk0b /tmp
causes mount to execute the equivalent of:
/sbin/mount_mfs -o nosuid -N -s 4000 /dev/dk0b /tmp
Additional options specific to filesystem types which are not
internally known (see the description of the -t option below) may
be described in the manual pages for the associated
-p Print mount information in fstab(5) format. Implies also the -v
-r The file system is to be mounted read-only. Mount the file sys-
tem read-only (even the super-user may not write it). The same
as the rdonly argument to the -o option.
-t ufs | external_type
The argument following the -t is used to indicate the file system
type. The type ufs is the default. The -t option can be used to
indicate that the actions should only be taken on filesystems of
the specified type. More than one type may be specified in a
comma separated list. The list of filesystem types can be pre-
fixed with ``no'' to specify the filesystem types for which
action should not be taken. For example, the mount command:
mount -a -t nonfs,mfs
mounts all filesystems except those of type NFS and MFS.
If the type is not one of the internally known types, mount will
attempt to execute a program in /sbin/mount_XXX where XXX is
replaced by the type name. For example, nfs filesystems are
mounted by the program /sbin/mount_nfs.
Most filesystems will be dynamically loaded by their mount pro-
grams if not already present in the kernel, using the vfsload(3)
subroutine. Because this mechanism requires writable temporary
space, the filesystem type containing /tmp must be compiled into
the kernel, and the filesystems containing /tmp and /usr/bin/ld
must be listed in /etc/fstab before any filesystems which might
be dynamically loaded.
-u The -u flag indicates that the status of an already mounted file
system should be changed. Any of the options discussed above
(the -o option) may be changed; also a file system can be changed
from read-only to read-write or vice versa. An attempt to change
from read-write to read-only will fail if any files on the
filesystem are currently open for writing unless the -f flag is
also specified. The set of options is determined by applying the
options specified in the argument to -o and finally applying the
-r or -w option.
-v Verbose mode.
-w The file system object is to be read and write.
Various, most of them are self-explanatory.
XXXXX filesystem is not available
The kernel does not support the respective filesystem type. Note that
support for a particular filesystem might be provided either on a static
(kernel compile-time), or dynamic basis (loaded as a kernel module by
kldload(8)). Normally, mount or its subprocesses attempt to dynamically
load a filesystem module if it has not been configured statically, using
vfsload(3). In this case, the above error message can also mean that you
did not have permission to load the module.
/etc/fstab file system table
mount(2), vfsload(3), fstab(5), kldload(8), mount_cd9660(8),
mount_ext2fs(8), mount_fdesc(8), mount_linprocfs(8), mount_mfs(8),
mount_msdos(8), mount_nfs(8), mount_ntfs(8), mount_null(8),
mount_nwfs(8), mount_portal(8), mount_procfs(8), mount_smbfs(8),
mount_std(8), mount_umap(8), mount_union(8), sysctl(8), umount(8)
It is possible for a corrupted file system to cause a crash.
After a successful mount, the permissions on the original mount point
determine if .. is accessible from the mounted file system. The minimum
permissions for the mount point for traversal across the mount point in
both directions to be possible for all users is 0111 (execute for all).
A mount utility appeared in Version 1 AT&T UNIX.
FreeBSD 4.8 June 16, 1994 FreeBSD 4.8