FreeBSD man pages : group (5)
GROUP(5) FreeBSD File Formats Manual GROUP(5)
group - format of the group permissions file
The file </etc/group> consists of newline separated ASCII records, one
per group, containing four colon `:' separated fields. These fields are
group Name of the group.
passwd Group's encrypted password.
gid The group's decimal ID.
member Group members.
Lines whose first non-whitespace character is a pound-sign (#) are com-
ments, and are ignored. Blank lines that consist only of spaces, tabs or
newlines are also ignored.
The group field is the group name used for granting file access to users
who are members of the group. The gid field is the number associated
with the group name. They should both be unique across the system (and
often across a group of systems) since they control file access. The
passwd field is an optional encrypted password. This field is rarely
used and an asterisk is normally placed in it rather than leaving it
blank. The member field contains the names of users granted the privi-
leges of group. The member names are separated by commas without spaces
or newlines. A user is automatically in a group if that group was speci-
fied in their /etc/passwd entry and does not need to be added to that
group in the /etc/group file.
The /etc/group file can be configured to enable the YP/NIS group
database. An entry whose name field consists of a plus sign (`+') fol-
lowed by a group name, will be replaced internally to the C library with
the YP/NIS group entry for the named group. An entry whose name field
consists of a single plus sign with no group name following, will be
replaced with the entire YP/NIS ``group.byname'' map.
If the YP/NIS group database is enabled for any reason, all reverse
lookups (i.e., getgrgid()) will use the entire database, even if only a
few groups are enabled. Thus, the group name returned by getgrgid() is
not guaranteed to have a valid forward mapping.
There are various limitations which are explained in the function where
they occur; see section SEE ALSO.
In older implementations, a group cannot have more than 200 members. The
maximum line length of /etc/group is 1024 characters. Longer lines will
be skipped. This limitation disappeared in FreeBSD 3.0. Older binaries
that are statically linked, depend on old shared libraries, or
non-FreeBSD binaries in compatibility mode may still have this limits.
passwd(1), setgroups(2), crypt(3), getgrent(3), initgroups(3), passwd(5),
The passwd(1) command does not change the group passwords.
A group file format appeared in Version 6 AT&T UNIX. The YP/NIS func-
tionality is modeled after SunOS and first appeared in FreeBSD 1.1. Sup-
port for comments first appeared in FreeBSD 3.0.
FreeBSD 4.8 September 29, 1994 FreeBSD 4.8