FreeBSD man pages : MAKEDEV (8)
MAKEDEV(8) FreeBSD/i386 System Manager's Manual MAKEDEV(8)
MAKEDEV - create system and device special files
MAKEDEV name ...
The shell script MAKEDEV found in the ``/dev'' directory, is used to cre-
ate the common special files. See intro(4) for a more complete discus-
sion of special files.
MAKEDEV takes any number of device names as arguments, where the names
are the common abbreviation for the device. There are two special
devices, ``std'' and ``local''. The former creates the standard devices
for the architecture. The latter is for devices specific to the local
site, and executes the shell file ``MAKEDEV.local''.
The i386 supports the following devices. Where a device name is followed
by a hash sign (``#''), the hash sign must be replaced by a unit number.
std the standard devices (console, fd/*, klog, kmem, mem, null,
stderr, stdin, stdout, tty)
local configuration specific devices
tty# standard PC COM ports
fd# ``floppy'' disk drives (3 1/2, 5 1/4)
pty# set of 32 master and slave pseudo terminals
da# SCSI disk drives
sa# SCSI tape drives
ch# SCSI changer devices
ses# SCSI SES/SAF-TE environmental devices
vty# set of 12 virtual console devices for syscons/pcvt/codrv
wd# (pc98 only) ``winchester'' disk drives (ST506, IDE, ESDI, RLL
ad# ``ATAPI'' disk drives (IDE).
ast# ``ATAPI'' tape drives.
acd# ``ATAPI'' CDROM drives.
/dev The special file directory.
ata(4), intro(4), config(8), mknod(8)
FreeBSD 4.8 June 5, 1993 FreeBSD 4.8